1. 
    
    1. <nobr id="c8bcf"><wbr id="c8bcf"><span id="c8bcf"></span></wbr></nobr>
        intel服務器網卡 | intel網卡 | intel光纖網卡 
        TeL: 020-85205216   
        電話:020-85205216
        020-85205216
        24小時熱線:136 1022 8025
        136 1022 8025
        傳真:020-22065085 email:179321907@qq.com
        網址:www.yuchaijiqi.com
        資訊詳情:

        網絡交換機的三種vlan劃分方法詳解

        時間:2020-11-07 17:49:13  作者:  來源:瀏覽:人次

        網絡交換機的三種vlan劃分方法詳解

        有很多的朋友提到了vlan的劃分,今天我們來看下具體應用。

        很多朋友在留言中也多次提到了華為交換機,華為也是在項目中用的比較多交換機,因此,我們今天以華為交換機為例,來講解vlan的3種劃分方法,360度來了解vlan。

        如果你以對vlan了解不多,那么這篇文章可以帶你深入學習vlan,都有詳細注釋。

        我們前面曾說到,關于vlan的劃分方法有很多,項目應用中較多的方法就是基于端口劃分vlan、基于mac地址劃分vlan、基于ip地址劃分vlan,要真正對vlan了解,必須熟悉這三次劃分方法,以便于根據實際項目進行應用。

        一、基于端口的vlan劃分方法
        這里面為了方便大家理解,直接用實例講解更清楚。
        1、組網需求
        如圖1所示,某企業的交換機連接有很多用戶,且相同業務用戶通過不同的設備接入企業網絡。為了通信的安全性,也為了避免廣播報文泛濫,企業希望業務相同用戶之間可以互相訪問,業務不同用戶不能直接訪問。

        可以在交換機上配置基于端口劃分VLAN,把業務相同的用戶連接的端口劃分到同一VLAN。

        也就是不同VLAN的用戶不能直接進行二層通信,同一VLAN內的用戶可以直接互相通信。

        2、配置步驟

        步驟1:在SwitchA創建VLAN2和VLAN3,并將連接用戶的端口分別加入VLAN。SwitchB配置與SwitchA類似,不再贅述。
        [Quidway] system-view          //進入配置視圖
        [Quidway] sysname SwitchA   //給交換機命名
        [SwitchA] vlan batch 2 3          //同時創建vlan2與vlan3
        [SwitchA] interface ethernet 0/0/1   //進入端口0/0/1
        [SwitchA-Ethernet0/0/1] port link-type access   //設置端口模式為access
        [SwitchA-Ethernet0/0/1] port default vlan 2      //將端口加入vlan2中
        [SwitchA-Ethernet0/0/1] quit   //退出
        [SwitchA] interface ethernet 0/0/2   //進入端口0/0/2
        [SwitchA-Ethernet0/0/2] port link-type access  //端口模式為access
        [SwitchA-Ethernet0/0/2] port default vlan 3    //將端口加入vlan3中
        [SwitchA-Ethernet0/0/2] quit   //退出


        步驟2 配置SwitchA上與SwitchB連接的端口類型及通過的VLAN。SwitchB配置與SwitchA類似,不再贅述。

        [SwitchA] interface ethernet 0/0/3 //進入端口0/0/3
        [SwitchA-Ethernet0/0/3] port link-type trunk   //設置端口模式為trunk
        [SwitchA-Ethernet0/0/3] port trunk allow-pass vlan 2 3   //trunk口允許通過vlan2與vlan3的數據包

        步驟3

        驗證配置結果將User1和User2配置在一個網段,比如192.168.100.0/24;將User3和User4配置在一個網段,比如192.168.200.0/24。

        User1和User2能夠互相ping通,但是均不能ping通User3和User4。User3和User4能夠互相ping通,但是均不能ping通User1和User2。

        二、基于MAC地址vlan劃分方法
        1、組網需求
        某個公司的網絡中,網絡管理者將同一部門的員工劃分到同一VLAN。為了提高部門內的信息安全,要求只有本部門員工的PC才可以訪問公司網絡。

        如圖2所示,PC1、PC2、PC3為本部門員工的PC,要求這幾臺PC可以通過SwitchA、Switch訪問公司網絡,如換成其他PC則不能訪問??梢耘渲没贛AC地址劃分VLAN,將本部門員工PC的MAC地址與VLAN綁定,從而實現該需求。

        2、操作步驟

        這里面弱電君對上面重復的注釋就不再解釋了,和上面一樣,大家也可以驗證下,經過上面的理解,是否能認識下面的配置代碼。

        步驟1 配置Switch

        # 創建VLAN
        [Quidway] system-view  
        [Quidway] vlan batch 10 100


        # 配置接口的PVID和加入VLAN
        [Quidway] interface ethernet 0/0/1  
        [Quidway-Ethernet0/0/1] port hybrid pvid vlan 100 //將接口以加入到vlan100

        [Quidway-Ethernet0/0/1] port hybrid untagged vlan 10   //untagged是指當數據離開端口時脫掉標簽,指定端口允許VLAN 10的數據幀通過,且發送時不帶VLAN標簽  
        [Quidway-Ethernet0/0/1] quit  #退出

        [Quidway] interface ethernet 0/0/2    #進入端口0/0/2
        [Quidway-Ethernet0/0/2] port hybrid tagged vlan 10 //tagged是指當數據離開端口時帶著標簽,指定允許VLAN 10的數據幀通過,且發送時必須帶有VLAN標簽  

        [Quidway-Ethernet0/0/2] quit


        # PC的MAC地址與VLAN10關聯
        [Quidway] vlan 10
        [Quidway-Vlan10] mac-vlan mac-address 22-22-22  
        //關聯pc1的mac地址
        [Quidway-Vlan10] mac-vlan mac-address 33-33-33 

         //關聯pc2的mac地址

        [Quidway-Vlan10] mac-vlan mac-address 44-44-44   

        //關聯pc3的mac地址

        [Quidway-Vlan10] quit


        # 使能接口的基于MAC地址劃分VLAN功能
        [Quidway] interface ethernet 0/0/1
        [Quidway-Ethernet0/0/1] mac-vlan enable 

         //起動端口的mac-vlan功能

        [Quidway-Ethernet0/0/1] quit

        三、基于IP子網的vlan劃分
        1、組網需求

        某企業擁有多種業務,如IPTV、VoIP、Internet等,每種業務使用的IP地址網段各不相同。為了便于管理,現需要將同一種類型業務劃分到同一VLAN中,不同類型的業務劃分到不同VLAN中。

        如圖3所示,Switch接收到用戶報文有數據、IPTV、語音等多種業務,用戶設備的IP地址網段各不相同?,F需要將不同類型的業務劃分到不同的VLAN中,通過不同的VLANID分流到不同的遠端服務器上以實現業務互通。

        這類在實際應用中是比較多的。

        2、配置思路

        采用如下的思路配置基于IP子網劃分VLAN:

        a、創建VLAN,確定每種業務所屬的VLAN。
        b、關聯IP子網和VLAN,實現根據報文中的源IP地址或指定網段確定VLAN。
        c、配置端口加入VLAN,實現基于IP子網的VLAN通過當前端口。
        d、配置VLAN劃分方式的優先級,確保優先選擇基于IP子網劃分VLAN。
        e、使能基于IP子網劃分VLAN。

        3、操作步驟

        步驟1 創建VLAN
        # 在Switch上創建VLAN100、VLAN200和VLAN300。
        [Quidway] system-view
        [Quidway] vlan batch 100 200 300


        步驟2 配置接口

        # 在Switch上配置接口Eth0/0/1為Hybrid類型,并加入VLAN100、VLAN200和VLAN300。

        [Quidway] interface ethernet 0/0/1
        [Quidway-Ethernet0/0/1] port link-type hybrid    //設置端口為hybrid模式

        [Quidway-Ethernet0/0/1] port hybrid untagged vlan100 200 300   //指定端口允許VLAN 100、vlan200、vlan300的數據幀通過,且發送時不帶VLAN標簽  

        [Quidway-Ethernet0/0/1] quit

        # 在Switch上配置接口Eth0/0/2加入VLAN100。

        [Quidway] interface ethernet 0/0/2
        [Quidway-Ethernet0/0/2] port link-type trunk
        [Quidway-Ethernet0/0/2] port trunk allow-pass vlan 100    //接口0/0/2加入vlan100

        [Quidway-Ethernet0/0/2] quit

        # 在Switch上配置接口Eth0/0/3加入VLAN200。
        [Quidway] interface ethernet 0/0/3
        [Quidway-Ethernet0/0/3] port link-type trunk
        [Quidway-Ethernet0/0/3] port trunk allow-pass vlan 200  //接口0/0/3加入vlan200

        [Quidway-Ethernet0/0/3] quit


        # 在Switch上配置接口Eth0/0/4加入VLAN300。
        [Quidway] interface ethernet 0/0/4
        [Quidway-Ethernet0/0/4] port link-type trunk
        [Quidway-Ethernet0/0/4] port trunk allow-pass vlan 300  //接口0/0/4加入vlan300

        [Quidway-Ethernet0/0/4] quit


        # 在Switch上配置接口Eth0/0/1使能基于IP子網劃分VLAN功能。
        [Quidway] interface ethernet 0/0/1
        [Quidway-Ethernet0/0/1] ip-subnet-vlan enable
        [Quidway-Ethernet0/0/1] quit


        步驟3 配置基于IP子網劃分VLAN

        # 在Switch上配置VLAN100與IP地址192.168.1.2/24關聯,優先級為2。

        [Quidway] vlan 100
        [Quidway-vlan100] ip-subnet-vlan 100 ip 192.168.1.2 24 priority 2
        [Quidway-vlan100] quit

        # 在Switch上配置VLAN200與IP地址192.168.2.2/24關聯,優先級為3。
        [Quidway] vlan 200
        [Quidway-vlan200] ip-subnet-vlan 200 ip 192.168.2.2 24 priority 3
        [Quidway-vlan200] quit

        # 在Switch上配置VLAN300與IP地址192.168.3.2/24關聯,優先級為4。
        [Quidway] vlan 300
        [Quidway-vlan300] ip-subnet-vlan 300 ip 192.168.3.2 24 priority 4
        [Quidway-vlan300] quit


        步驟4 驗證配置結果

        在Switch上執行以下命令,顯示信息如下:
        [Quidway] display ip-subnet-vlan vlan all
        ----------------------------------------------------------------
        Vlan Index IpAddress SubnetMask Priority
        ----------------------------------------------------------------
        100 1 192.168.1.2 255.255.255.0 2
        200 1 192.168.2.2 255.255.255.0 3
        300 1 192.168.3.2 255.255.255.0 4
        ----------------------------------------------------------------
        ip-subnet-vlan count: 3 total count: 3

        即為組網配置成功。

        網站首頁| 公司簡介| 資訊中心| 產品展示| 工程案例| 招商加盟| 聯系我們

        廣州吉悅計算機科技有限公司© 2005 - 2010 All Rights Reserved.
        公司地址:廣州市天河區石牌西路8號展望數碼廣場850A  聯系電話020-85205216 Email:179321907@qq.com
        網站備案號:粵ICP備19142146號    Powered by 【廣州吉悅計算機科技有限公司】  

        国产精品久久久-把筷子放屁眼里不能掉的作文-免费看黑人男阳茎进女阳道视频-一个人看的免费视频www-欧美高清性xxxxxxx-精品卡一卡二新区乱码仙踪林